Welcome, Guest Login

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

LibAppBladeUniversal.a cupported architectures

Irina Mar 18, 2015 02:27PM EDT

I'm trying to build projects for Iphone5s, it requires arm x86_64 architecture.
Got errors during build:


ld: warning: ignoring file /Users/irina/bills/platforms/ios/LibAppBladeUniversal.a, missing required architecture x86_64 in file /Users/irina/bills/platforms/ios/LibAppBladeUniversal.a (3 slices)

Undefined symbols for architecture x86_64:
"_OBJC_CLASS_$_AppBlade", referenced from:
objc-class-ref in AppBladePlugin.o
(maybe you meant: _OBJC_CLASS_$_AppBladePlugin)
ld: symbol(s) not found for architecture x86_64

Is there a way to build app using your library for that arch&

Up 0 rated Down
Michael Johnson Mar 18, 2015 02:48PM EDT AppBlade Agent
I think the following questions and answers on StackOverflow may be relevant:

http://stackoverflow.com/questions/21985909/no-architectures-to-compile-for-only-active-arch-yes-active-arch-x86-64-valid
http://stackoverflow.com/questions/22328882/xcode-5-1-no-architectures-to-compile-for-only-active-arch-yes-active-arch-x
http://stackoverflow.com/questions/22696878/iphone-5s-specific-error-no-architectures-to-compile-for-only-active-arch-yes

Let us know if that helps.
Up 0 rated Down
simonita1@yandex.ru Apr 30, 2015 11:03AM EDT
Thanks a lot, it helped

This question has received the maximum number of answers.

support@appblade.com
https://cdn.desk.com/
false
appblade
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete