Welcome, Guest Login

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

AppBlade iOS SDK CocoaPods

Sean May 18, 2016 10:25PM EDT

I am trying to install the AppBlade SDK to my mixed Swift and Obj-C project. In my CocoaPod I am required to 'use_frameworks!', but this causes an error:

The 'NAME' target has transitive dependencies that include static binaries: (/PATH/Pods/PLCrashReporter/iOS Framework/CrashReporter.framework)

What can I do to work around this? I would like to have the SDK in my project to take advantage of all of the App Blade features besides just MDM deployment for Enterprise Apps.

Thanks,

-Sean

1 Community Answers

Best Answer
Michael Johnson May 20, 2016 02:54PM EDT

Hey Sean,

We have a known problem with CocoaPods that we are currently working on -- CocoaPods changed how pods can be defined and it broke our integration. They removed the ability to link to private static libraries. Although we can switch to source linking, one of our dependencies is always using static library linking and we are not sure when or if they will update as well (PLCrashReporter). We may need to hack around them. In the meantime, we recommend using the old school method of linking in our SDK, detailed at https://github.com/AppBlade/AppBladeSDK/wiki/Embedding-our-SDK#ios-sdk .


This question has received the maximum number of answers.

support@appblade.com
https://cdn.desk.com/
false
appblade
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete